Email delays and duplicate emails reported in North America
Incident Report for Aventri
Resolved
This incident has been resolved.
Posted Feb 15, 2020 - 05:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2020 - 01:06 EST
Investigating
We are continuing to investigate this issue.
Posted Feb 14, 2020 - 17:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2020 - 16:25 EST
Investigating
We have been investigating reports of a delay in sending outbound emails as well as emails being received multiple times in North America, this will affect the Marketing module. We will provide updates regularly.
Posted Feb 14, 2020 - 15:44 EST
This incident affected: Email.