Monitoring - Loading times of the impacted sections of the NA server were restored to normal levels. We are currently monitoring the performance of the NA server.
Apr 16, 2024 - 23:18 EDT
Update - We are continuing to investigate issue of extended loading times on NA server. While we are working on the matter and permanent fix we can see the loading times improved across the impacted sections of the platform.
Apr 16, 2024 - 22:07 EDT
Investigating - We are currently investigating reports of extended loading times in reporting and data upload sections of the platform on NA server.
Apr 16, 2024 - 19:58 EDT

About This Site

Stova Service Status Dashboard




Contact Support:

Global, and America
P: +1 800 516 4265



Europe Middle East, Africa
P: +44 845 077 2803



Australia Asia Pacific
P: +61 2 8213 4259



Global support : support@stova.io

Web ? Operational
Email ? Operational
Stova Attendee Mobile Apps ? Operational
Public API ? Operational
Zentila Application ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

Unresolved incident: Investigating NA server downgraded performance.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.

Apr 4, 2024

No incidents reported.