Email delivery delays
Incident Report for Aventri
Resolved
All messages are being delivered within standard timeframes.
Posted 3 months ago. Aug 06, 2019 - 13:52 EDT
Investigating
We are currently experiencing some delays in email delivery, the teams are investigating the issue
Posted 3 months ago. Aug 06, 2019 - 10:53 EDT
This incident affected: Email.