Brief Interruption of Service in North America Region
Incident Report for Aventri
Postmortem

We have identified the root cause of this service interruption and have permanently corrected the issue. The disruption was caused by replication logs on one of our Master databases being retained longer than scheduled, thereby causing a low storage condition on a log storage drive. The Aventri platform uses several methods to ensure redundancy and data reliability. One of these methods relies on database replication from master databases to replica databases in real-time. One of the replica instances was configured with a conflicting setting that caused the master database to not properly replicate to it and thus preventing it from clearing its replication log. The immediate resolution was for our Ops team to manually clear the replication log, thereby allowing the Master database to resume processing transactions. We have also taken steps to ensure this condition doesn't occur again by verifying all of our replication database configuration across all regions to ensure the proper configuration is present.

Once again, we apologize for this brief disruption as we strive to provide our customers the best level of reliability and service possible.

Posted 9 months ago. Feb 06, 2019 - 23:22 EST

Resolved
Unfortunately we experienced an incident in our North American region lasting approximately 10 minutes that caused an interruption of service to the Aventri Core Platform and APIs. We are currently conducting a root cause analysis and will update this incident report within 24 hours.

EMEA and APAC regions were unaffected. All mobile apps in all regions were unaffected also.

We sincerely apologize for any inconvenience this may have caused our customers and are working diligently to ensure it doesn't happen again.
Posted 9 months ago. Jan 31, 2019 - 17:23 EST