All Systems Operational

About This Site

Stova Service Status Dashboard




Contact Support:

Global, and America
P: +1 800 516 4265



Europe Middle East, Africa
P: +44 845 077 2803



Australia Asia Pacific
P: +61 2 8213 4259



Global support : support@stova.io

Web ? Operational
Email ? Operational
Stova Attendee Mobile Apps ? Operational
Public API ? Operational
Zentila Application ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024
Resolved - This incident has been resolved.
Mar 21, 08:37 EDT
Identified - The root cause of the Stripe Connect payment gateway not processing attendee payments issue was identified and we are currently working on implementing the fix.
Mar 20, 23:56 EDT
Update - We are continuing to investigate the issue of Stripe Connect payment gateway not processing attendee payments.
Mar 20, 23:32 EDT
Investigating - We are currently investigating the issue of Stripe Connect payment gateway not processing attendee payments.
Mar 20, 19:22 EDT
Mar 20, 2024
Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024
Resolved - This incident has been resolved.
Mar 14, 20:03 EDT
Monitoring - A cause of an intermittent service connectivity issue in the Stova platform for North America was located and fix applied. Our team is closely monitoring performance and the results.
Mar 14, 19:17 EDT
Investigating - We’re experiencing an intermittent service connectivity issue in the Stova platform for North America. Our team is aware of the issue and is currently working to restore the services. Users may see a 504 error message or slowness in the system. We will provide updates once full service is restored.
Mar 14, 17:13 EDT
Resolved - This incident has been resolved.
Mar 14, 12:25 EDT
Monitoring - A fix has been implemented and we are monitoring the results.
Mar 14, 12:21 EDT
Investigating - We’re experiencing a service outage with 504 Gateway Time-out in North America Server. Our team is aware of the issue and is currently working to restore the service(s).
Mar 14, 11:16 EDT