Email Delays in North America
Incident Report for Aventri
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 17:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2020 - 14:02 EDT
Investigating
We have been investigating reports of a delay in sending outbound emails in North America, this will affect Registration, Marketing, Networking & Abstracts. We will provide updates regularly.
Posted Jun 09, 2020 - 13:00 EDT
This incident affected: Email.